ADVISORIES
POSTED BY: Chariton Karamitas / 14.04.2021

WhatsApp exposure of TLS 1.2 cryptographic material to third party apps

CENSUS ID:CENSUS-2021-0002
CVE ID:CVE-2021-24027
Affected Products:WhatsApp Messenger for Android, versions prior to 2.21.4.18
Class:Exposure of Sensitive Information to an Unauthorized Control Sphere (CWE-497)
Discovered by:Chariton Karamitas

CENSUS identified that versions prior to 2.21.4.18 of WhatsApp for Android allowed third party apps to access WhatsApp TLS 1.2 cryptographic material, as this was stored in "app-specific external storage". On Android 9 and previous versions of Android, the material is exposed to any third party app that bears the READ_EXTERNAL_STORAGE or WRITE_EXTERNAL_STORAGE permission. On Android 10 a malicious app would also require the requestLegacyExternalStorage attribute to access the files. Through the installation of a malicious app, or alternatively, through the exploitation of a vulnerable app (or Android component) that resides on a WhatsApp user's mobile device, remote actors were able to control the victim user's TLS session cryptographic secrets and could thus perform Man-in-The-Middle attacks to WhatsApp communications. Research has shown that exploitation of this vulnerability can lead to remote code execution on the victim device. CENSUS strongly recommends updating WhatsApp to version 2.21.4.18 or greater. This is a serious vulnerability which could be abused for surveillance purposes.


POSTED BY: Rayd Debbas / 17.02.2021

Canary Mail and MailCore2 library missing certificate validation check on IMAP STARTTLS

CENSUS ID:CENSUS-2021-0001
CVE ID:CVE-2021-26911
Affected Products:Canary Mail for iOS and MacOS versions 3.20 and 3.21, MailCore2 library version 0.6.4
Class:Improper Certificate Validation (CWE-295)
Discovered by:Rayd Debbas

CENSUS identified that the Canary Mail software in versions 3.20 and 3.21 (and possibly previous versions) is missing a certificate validation check when performing an IMAP connection configured with STARTTLS. This vulnerability allows man-in-the-middle attackers to collect a victim user's email credentials (while these are communicated to the IMAP service), to access email messages and perform other IMAP actions to the victim account, but also to modify email messages while in-transit to Canary Mail. CENSUS strongly recommends to iOS and MacOS users of the Canary Mail software to update to version 3.22, as this version carries a fix for the aforementioned vulnerability. The same vulnerability also affects other software that are based on the MailCore2 library (including version 0.6.4). A patch for the library is publicly available, however this has not been incorporated yet into an official library release.


POSTED BY: George Poulios / 21.10.2020

Microchip cryptoauthlib atcab_sign_base buffer overflow

CENSUS ID:CENSUS-2020-0003
CVE ID:CVE-2019-16128
Affected Products:cryptoauthlib versions prior to "20191122"
Class:Buffer Copy without Checking Size of Input ('Classic Buffer Overflow')(CWE-120)
Discovered by:George Poulios

CENSUS identified a buffer overflow vulnerability in the atcab_sign_base function of the cryptoauthlib library. This library is part of the standard SDK provided by Microchip and is used to drive the operation of cryptographic co-processors sold by the vendor, such as the ATECC608A. An attacker with physical access to an embedded device where a microcontroller unit executes a vulnerable version of this library, may be able to execute arbitrary code on the microcontroller, by supplying malicious input to the microcontroller. Affected manufacturers of embedded systems that use Microchip cryptographic co-processors, are strongly recommended to update to at least version "20191122" of the "cryptoauthlib" library.


POSTED BY: George Poulios / 21.10.2020

Microchip cryptoauthlib atcab_genkey_base buffer overflow

CENSUS ID:CENSUS-2020-0004
CVE ID:CVE-2019-16129
Affected Products:cryptoauthlib versions prior to "20191122"
Class:Buffer Copy without Checking Size of Input ('Classic Buffer Overflow')(CWE-120)
Discovered by:George Poulios

CENSUS identified a buffer overflow vulnerability in the atcab_genkey_base function of the cryptoauthlib library. This library is part of the standard SDK provided by Microchip and is used to drive the operation of cryptographic co-processors sold by the vendor, such as the ATECC608A. An attacker with physical access to an embedded device where a microcontroller unit executes a vulnerable version of this library, may be able to execute arbitrary code on the microcontroller, by supplying malicious input to the microcontroller. Affected manufacturers of embedded systems that use Microchip cryptographic co-processors, are strongly recommended to update to at least version "20191122" of the "cryptoauthlib" library.